Minggu, 03 November 2013

Pengertian BOOTP (Bootstap protocol)

Bootstrap Protocol (BOOTP)

Dikembangkan untuk membuat komputer menginisialisasi dirinya pada suatu jaringan (RFC951).

Dibandingankan dengan DHCP memang terbatas, tetapi karena DHCP dibangun di atas BOOTP, maka perlu untuk memahami struktur pesan dan protocol BOOTP sebelum memperhatikan DHCP lebih jauh.

Lebih lanjut, karena kebanyakan implementasi DHCP juga berfungsi sebagai server BOOTP, maka BOOTP harus dipahami.

Biasanya BOOTP mencakup komputer yang meminta informasi diperlukan untuk menginisialisasi.


Komputer dapat meminta 3 informasi kepada server, yaitu :

1. Informasi mengenai IP Address.
Berguna supaya komputer dapat menginisialisasi interface jaringannya.

2. Informasi IP Address suatu mesin di server (bootserver).
Berguna untuk menyediakan sebuah file bagi sebuah mesin untk load dan berjalan.

3. Nama file yang harus diload.

Dengan informasi tersebut, client dapat menginisialisasi jaringannya, terhubung ke bootserver (alamatnya sekarang diketahui), dan meload bootfile yang ditunjuk dengan menggunakan protocol sederhana seperti TFTP.

Bootfile biasanya berisi informasi lain yang dibutuhkan client untuk konfigurasi, dalam format yang memiliki signifikansi hanya dengan client.

Selain itu bootfile dapat menjadi gambaran software keseluruha yang akan diload dan dijalankan oleh client.


BOOTP berupa konsep protocol standart. Statusnya dianjurkan. Spesifikasi BOOTP
dapat ditemukan pada RFC 951 - Bootstrap Protocol and RFC 1497 - BOOTP Vendor
Information Extensions. 

LAN memungkinkan host tanpa harddisk sebagai workstation, router, terminal
concentrator dan masih banyak lagi. Host tanpa harddisk membutuhkan mekanisme untuk
boot dengan di-remote melalui sebuah jaringan. BOOTP protocol digunakan untuk me-
remote booting melalui jaringan IP. BOOTP memperbolehkan protocol IP minimal
sehingga tidak mengganggu informasi konfigurasi yang tidak melakukan apa-apa, biasanya
disimpan di ROM, untuk mendapatkan informasi yang cukup untuk memulai proses
download dengan menggunakan kode boot yang dibutuhkan. BOOTP tidak mendefinisikan
cara untuk men-download selesai, tetapi proses ini biasanya menggunakan TFTP
sebagaimana dideskripsikan RFC 906 – Bootstrap loading menggunakan TFTP.

BOOTP memiliki kegunaan yang sama dengan DHCP, hanya BOOTP didesain
untuk manual pre-configuration dari informasi host di dalam suatu server database. BOOTP
dan DHCP didesain agar bisa route ke jaringan. 


•Kelebihan BOOTP 
Bootp memiliki keunggulan antara lain:

- Tidak perlu harddisk, karena dapat digantikan perannya oleh Ethernet card dan BOOT Lan
- Memiliki log file sehingga dapat dilihat sewaktu-waktu penyebab error dengan melihat
log file tersebut.

•Kelemahan BOOTP 
Bootp memiliki kelemahan sebagai berikut:

- Harus dilakukan secara manual sehingga resiko menimbulkan masalah cukup besar.
- Pengiriman pesan yang tidak dapat diandalkan karena menggunakan UDP.
- OS sekarang misalnya Windows sudah tidak memasukkan BOOTP dalam konfigurasi jaringannya.

Minggu, 13 Oktober 2013

Cara Download dan Install Dota 2 di Steam

Bagi teman-teman yang hobby main game online terutama dota khususnya. mungkin sekarang lagi marak dimainkan oleh beberapa orang tentang Dota 2. disini saya mau berbagi dikit cara install dota 2 pada PC atau laptop.
Berikut sedikit cara yang saya lakukan saat diberi Info dari temen yang hobynya main dota 2:

1. Daftar dulu di steam klik Disini
2. Install steam jika belom punya dan sekaligus di update (jika pake modem, soalnya besar datanya)
3. Pada kotak search the store ketik DOTA 2 lalu enter dan akan muncul berikut Disini
4. Lalu klik SIGN - UP for a dota 2 Invite dan isi angket yang ditampilkan (semua wajib diisi)
5. Setelah diisi tunggu sampai steam Invite dota 2 dengan mengirim dota 2 enjoy game play waktunya engga        tentu ada yang 1 minggu ada yang cuma beberapa jam saja.
6. Setelah diinvite silahkan download dota 2 nya file size kira-kira hampir 7-8 GB.
7. Setelah itu buka icon steam, lakukan log in, dan buka library.
8. Lihat icon dota 2 dan klik play dan selamat menikmati.